0

I have created an Enhanced Cluster of Kubernetes (OKE) in Oracle Cloud (OCI). Some cluster pods connect to VM instances outside OKE but in the same VCN subnet as the pods.

I want these connections to use domain names instead of IP addresses. To achieve this I created an IP to domain mapping in hosts block in core-dns configmap that was automatically created by OKE.

Issue: after editing the entry in configmap and a proper rollout, after around 12 hours it reverts to its original state.

I am unable to determine what is causing this behaviour as this is an enhanced cluster and not a Basic one. Is there a recommended way to do this host mapping so that custom changes will be preserved?

Coredns configmap edit code below (custom code starts and End mentioned in below YAML):

kubectl edit cm coredns -n kube-system

data:
  Corefile: |-
    .:53 {
      errors

      health {

        lameduck 5s

      }

      ready

      kubernetes cluster.local in-addr.arpa ip6.arpa {

        pods insecure

        fallthrough in-addr.arpa ip6.arpa

      }

      prometheus :9153

      forward . /etc/resolv.conf

      cache 30

      loop

      reload

      loadbalance
#Custom Code Starts
      hosts {

        10.110.2.60 citus.exotel.local

        10.110.2.60 citus-coordinator-master.exotel.local

        10.110.2.252 citus-coordinator-replica.exotel.local

        10.110.2.96 citus-worker-0.exotel.local

        10.110.2.59 redis.exotel.local

        10.110.2.8 kafka.exotel.local

        10.110.2.8 kafka-0.exotel.local

        10.110.2.250 kafka-1.exotel.local

        10.110.2.142 kafka-2.exotel.local

        fallthrough

      }
#Custom Code Ends 
    }

    import custom/*.server

kind: ConfigMap

metadata:


  name: coredns

1 Answer 1

0

VRF Lite Configuration on a Cisco Router

Define the VRFs:

ip vrf HR
 rd 100:1
 route-target export 100:1
 route-target import 100:1
!
ip vrf Finance
 rd 100:2
 route-target export 100:2
 route-target import 100:2
!
ip vrf IT
 rd 100:3
 route-target export 100:3
 route-target import 100:3

Assign Interfaces to VRFs:

interface GigabitEthernet0/0
 ip vrf forwarding HR
 ip address 192.168.1.1 255.255.255.0
!
interface GigabitEthernet0/1
 ip vrf forwarding Finance
 ip address 192.168.2.1 255.255.255.0
!
interface GigabitEthernet0/2
 ip vrf forwarding IT
 ip address 192.168.3.1 255.255.255.0

Configure Routing:

router ospf 1
 vrf HR
  network 192.168.1.0 0.0.0.255 area 0
!
router ospf 2
 vrf Finance
  network 192.168.2.0 0.0.0.255 area 0
!
router ospf 3
 vrf IT
  network 192.168.3.0 0.0.0.255 area 0
New contributor
warashi nguyen is a new contributor to this site. Take care in asking for clarification, commenting, and answering. Check out our Code of Conduct.
1
  • How to apply this on oracle cloud kubernetes cluster Commented Jun 24 at 6:35

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .